[Linux] 在 Centos 6.2 上安裝 python 的 lxml 模組

[Linux] 在 Centos 6.2 上安裝 python 的 lxml 模組

因為專案的需要,要在 CentOS 6.2 上 (python 2.6) 安裝 lxml 這個模組,

嘗試錯誤了幾次,決定來記錄一下~

 

1. 安裝 libxml2-devel 和 libxslt-devel

原本應該只需要安裝 libxml2-devel,不過在編譯 lxml 時似乎會參考到 xslt 相關的標頭檔,

因此連 libxslt-devel 也得安裝:

sudo yum -y install libxml2-devel libxslt-devel

 

2. 安裝 lxml

這邊用 easy_install 或 pip 都可以:

easy_install lxml
pip install lxml

 

參考資料:Setup.py: install lxml with Python2.6 on CentOS

 

(本頁面已被瀏覽過 42 次)

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料