[Python] 在 CentOS 7 上安裝 Pillow 遇到缺少 libjpeg 的錯誤訊息

[Python] 在 CentOS 7 上安裝 Pillow 遇到缺少 libjpeg 的錯誤訊息

最近在公司的 Machine Learning 比賽中,要比數字辨識,

免不了要將 training set 的圖做一些影像處理,來增加 training set 的量~

 

在 Python 裡面可以用 Pillow (PIL 的後繼者) 來做圖片的處理,

Mac 上用 pip 很順利的就將 pillow 裝起來了,

但在 CentOS 7 上卻遇到了需要 jpeg 的錯誤訊息:

testuser@localhost ~ $ pip install pillow
...
File "/usr/lib64/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "/usr/lib64/python2.7/distutils/command/build_ext.py", line 339, in run
self.build_extensions()
File "/tmp/pip-build-hQxblO/pillow/setup.py", line 512, in build_extensions
' using --disable-%s, aborting' % (f, f))
ValueError: jpeg is required unless explicitly disabled using --disable-jpeg, aborting

 

看了一下,系統的 libjpeg 早就已經裝好了,為啥還會有這個錯誤呢?

研究了半天,原來需要的是 libjpeg-devel 開發者套件,而不只是 libjpeg…

用下面的指令將 libjpeg-devel 安裝好:

sudo yum install -y libjpeg-devel

 

再用 pip 安裝一次 pillow,這次就沒有遇到問題囉:

testuser@localhost ~ $ pip install pillow
Collecting pillow
Using cached Pillow-3.2.0.tar.gz
Building wheels for collected packages: pillow
Running setup.py bdist_wheel for pillow ... done
Stored in directory: /home/testuser/.cache/pip/wheels/bc/7e/44/ff18d3be67549e6336f50ace425e05269579fd33140dfe17c7
Successfully built pillow
Installing collected packages: pillow
Successfully installed pillow-3.2.0

 

(本頁面已被瀏覽過 135 次)

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料