[Ubuntu] 將 Ubuntu 15.04 升級至 15.10,安裝 VirtualBox 5.1

[Ubuntu] 將 Ubuntu 15.04 升級至 15.10,安裝 VirtualBox 5.1

今天裝好一台 Ubuntu 15.04 的機器,接著想要在裡面裝 VirtualBox,

卻發現不給裝,說 libdevmapper 的版本太舊:

Screenshot from 2016-07-22 10:41:18

 

查了一下,有人說是因為裝了不是給正確平台使用的 VirtualBox…

的確從 VirtualBox 的 Linux 下載頁那邊,我只看到了 Ubuntu 16.04, 15.10, 14.04 的版本,

所以後來是直接拿 Ubuntu 15.10 的版本來裝,而遇到了問題…

(其實 VirtualBox 是有給 Ubuntu 15.04 的版本,但因為寫在一起,所以沒看到↓:

Ubuntu 14.04 (“Trusty”) / 14.10 (“Utopic”) / 15.04 (“Vivid”) )

 

想想那就直接升到 15.10 版本好了,

先用 do-release-upgrade -V 看一下現在的版本,是 15.04.14.2:

testuser@localhost ~ $ do-release-upgrade -V
do-release-upgrade: version 15.04.14.2

 

再用 do-release-upgrade -c 檢查一下有沒有新版的 Ubuntu,答案是有 15.10:

testuser@localhost ~ $ do-release-upgrade -c
Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife
New release '15.10' available.
Run 'do-release-upgrade' to upgrade to it.

 

直接執行 do-release-upgrade 開始執行升級吧,中間遇到一些問題,

應該都是按 y, yes, Enter 鍵就行了,最後重開機後,就升級成功了:

do-release-upgrade

 

執行 lsb_release -a 看一下現在的版本,果然變成 15.10 了:

testuser@localhost ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:    15.10
Codename:   wily

 

再裝一次 VirtualBox,現在就可以正常安裝,沒有再出現 libdevmapper 太舊的訊息囉: 

Screenshot from 2016-07-22 11-53-48  

 

(本頁面已被瀏覽過 89 次)

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料