[Dart] 在 Mac 上安裝 Dart SDK

[Dart] 在 Mac 上安裝 Dart SDK

之前有 在 Mac 上安裝 Flutter 開發環境

不過反而不曉得要怎麼單獨執行 Dart 寫的程式…

今天就來安裝一下 Dart SDK 吧~

 

在 Mac 上用 Homebrew 安裝 Dart SDK:

brew tap dart-lang/dart
brew install dart

 

這樣就安裝好了~看一下目前的版本:

$ dart --version
Dart SDK version: 3.0.3 (stable) (Wed May 31 15:35:05 2023 +0000) on "macos_x64"

 

隨便寫個 test.dart 來測試一下:

void main() {
  String name = 'John';
  int age = 25;
  print(name);
  print(name + ' is ' + age.toString() + ' years old.');
}

 

接著執行  dart <filename> 來跑這個程式:

$ dart test.dart

John
John is 25 years old.

 

這樣子就可以開始學習 Dart 語言啦~

 

參考資料:Get the Dart SDK | Dart

(本頁面已被瀏覽過 32 次)

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *

這個網站採用 Akismet 服務減少垃圾留言。進一步了解 Akismet 如何處理網站訪客的留言資料