[Linux] 解決 ld-linux.so.2: bad ELF interpreter 的問題

[Linux] 解決 ld-linux.so.2: bad ELF interpreter 的問題

今天在 CentOS 6.2 x64 上面整合別人的程式時,

突然遇到了如下的錯誤訊息:

-bash: ./testserver: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

 

查了一下,原來是需要在 x64 的 CentOS 上面,安裝給 32-bit 程式用的 glibc 函式庫才行~

因此只要用 yum 裝一下 glibc 就行囉~

yum -y install glibc.i686

 

裝好的話,再執行程式就沒有問題了~ ^^

(本頁面已被瀏覽過 651 次)

發表迴響

你的電子郵件位址並不會被公開。

This site uses Akismet to reduce spam. Learn how your comment data is processed.