[Cordova] 將 app 安裝到 iPhone 時,Xcode 出現 Untrusted Developer 錯誤訊息?

[Cordova] 將 app 安裝到 iPhone 時,Xcode 出現 Untrusted Developer 錯誤訊息?

今天在把自己開發的 Cordova app 用 Xcode 安裝到 iPhone 時,

出現了 Untrusted Developer: Your device management settings do not allow using apps 的訊息:

 

這也不是我第一次看到這訊息

所以就去 iPhone > Settings > General,

想找一下 Device Management 的設定,不料這次卻找不到?!

 

上網找了一下,有人說可以自己點 iPhone 上的 app,

再去看 Device Management 會不會跑出來,

不過試過了也是沒用…

移掉 iPhone 上的 app 再重新安裝,也是無用…

 

後來總算找到一個可以成功的做法了,

問題原因可能是我有修改 app 的 bundle ID

(把 idv.ephrain.multilibrarylogin2 改成 idv.ephrain.multilibrarylogin),

所以 iPhone 上的 profile 還存在舊的 bundle ID…

 

解決方法是到 Xcode > Window > Device and Simulators,

在 iPhone 上按右鍵 > Show Provisioning Profiles:

 

這邊可以看到我舊的 multilibrarylogin2 的 profile,

按下 – 鈕全部刪除掉:

 

接著把這個 app 也按 – 鈕刪除掉:

 

再重新從 Xcode 安裝 app 到 iPhone,

這次就沒有問題囉~

(本頁面已被瀏覽過 9 次)

發表迴響

你的電子郵件位址並不會被公開。

這個網站採用 Akismet 服務減少垃圾留言。進一步瞭解 Akismet 如何處理網站訪客的留言資料